What’s Vulnerable › Vulnerabilities
CVE-2024-37895: API Key Leak in lobe-chat
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-17 · updated 2026-06-17
- Weakness: CWE-200
Description
Lobe Chat is an open-source LLMs/AI chat framework. In affected versions if an attacker can successfully authenticate through SSO/Access Code, they can obtain the real backend API Key by modifying the base URL to their own attack URL on the frontend and setting up a server-side request. This issue has been addressed in version 0.162.25. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- lobehub lobe-chat: before 0.162.25 — fixed in 0.162.25
How to fix
Upgrade to a fixed version: lobehub lobe-chat 0.162.25. Check the vendor advisory for mitigations.
References
- https://github.com/lobehub/lobe-chat/security/advisories/GHSA-p36r-qxgx-jq2v
- https://github.com/lobehub/lobe-chat/security/advisories/GHSA-p36r-qxgx-jq2v
Get alerted when CVE-2024-37895 or the next vulnerability affects your stack