What’s Vulnerable › Vulnerabilities
CVE-2024-37901: XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-31 · updated 2026-06-17
- Weakness: CWE-95
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with edit right on any page can perform arbitrary remote code execution by adding instances of `XWiki.SearchSuggestConfig` and `XWiki.SearchSuggestSourceClass` to their user profile or any other page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability has been patched in XWiki 14.10.21, 15.5.5 and 15.10.2.
Affected products
- xwiki-platform: from 9.2 before 14.10.21; from 15.0 before 15.5.5; from 15.6 before 15.10.2 — fixed in 14.10.21, 15.10.2, 15.5.5
How to fix
Upgrade to a fixed version: xwiki-platform 14.10.21, 15.10.2, 15.5.5. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/0b135760514fef73db748986a3311f3edd4a553b
- https://github.com/xwiki/xwiki-platform/commit/742cd4591642be4cdcaf68325f17540e0934e64e
- https://github.com/xwiki/xwiki-platform/commit/9ce3e0319869b6d8131fc4e0909736f7041566a4
- https://github.com/xwiki/xwiki-platform/commit/bbde8a4f564e3c28839440076334a9093e2b4834
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-h63h-5c77-77p5
- https://jira.xwiki.org/browse/XWIKI-21473
Get alerted when CVE-2024-37901 or the next vulnerability affects your stack