What’s Vulnerable › Vulnerabilities
CVE-2024-37903: Mastodon has improper authorship check on audience extension for existing posts
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-05 · updated 2026-06-17
- Weakness: CWE-862
Description
Mastodon is a self-hosted, federated microblogging platform. Starting in version 2.6.0 and prior to versions 4.1.18 and 4.2.10, by crafting specific activities, an attacker can extend the audience of a post they do not own to other Mastodon users on a target server, thus gaining access to the contents of a post not intended for them. Versions 4.1.18 and 4.2.10 contain a patch for this issue.
Affected products
- mastodon: from 2.6.0 before 4.1.18; from 4.2.0 before 4.2.10 — fixed in 4.1.18, 4.2.10
How to fix
Upgrade to a fixed version: mastodon 4.1.18, 4.2.10. Check the vendor advisory for mitigations.
References
- https://github.com/mastodon/mastodon/commit/a1c7aae28aecf06659c5b18cfa131b37cd1512a3
- https://github.com/mastodon/mastodon/commit/d4bf22b632ea8b1174375c4966a6768ab66393b6
- https://github.com/mastodon/mastodon/releases/tag/v4.1.18
- https://github.com/mastodon/mastodon/releases/tag/v4.2.10
- https://github.com/mastodon/mastodon/security/advisories/GHSA-xjvf-fm67-4qc3
- https://github.com/mastodon/mastodon/commit/a1c7aae28aecf06659c5b18cfa131b37cd1512a3
- https://github.com/mastodon/mastodon/commit/d4bf22b632ea8b1174375c4966a6768ab66393b6
- https://github.com/mastodon/mastodon/releases/tag/v4.1.18
- https://github.com/mastodon/mastodon/releases/tag/v4.2.10
- https://github.com/mastodon/mastodon/security/advisories/GHSA-xjvf-fm67-4qc3
Get alerted when CVE-2024-37903 or the next vulnerability affects your stack