What’s Vulnerable › Vulnerabilities
CVE-2024-37905: Improper Access Control and Incorrect Authorization in github.com/goauthentik/authentik
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-28 · updated 2026-06-17
- Weakness: CWE-284
Description
authentik is an open-source Identity Provider that emphasizes flexibility and versatility. Authentik API-Access-Token mechanism can be exploited to gain admin user privileges. A successful exploit of the issue will result in a user gaining full admin access to the Authentik application, including resetting user passwords and more. This issue has been patched in version(s) 2024.2.4, 2024.4.2 and 2024.6.0.
Affected products
- goauthentik authentik: before 2024.2.4; from 2024.4.0 before 2024.4.3 — fixed in 2024.2.4, 2024.4.3
How to fix
Upgrade to a fixed version: goauthentik authentik 2024.2.4, 2024.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/goauthentik/authentik/releases/tag/version%2F2024.2.4
- https://github.com/goauthentik/authentik/releases/tag/version%2F2024.4.3
- https://github.com/goauthentik/authentik/releases/tag/version%2F2024.6.0
- https://github.com/goauthentik/authentik/security/advisories/GHSA-c78c-2r9w-p7x4
- https://github.com/goauthentik/authentik/releases/tag/version%2F2024.2.4
- https://github.com/goauthentik/authentik/releases/tag/version%2F2024.4.3
- https://github.com/goauthentik/authentik/releases/tag/version%2F2024.6.0
- https://github.com/goauthentik/authentik/security/advisories/GHSA-c78c-2r9w-p7x4
Get alerted when CVE-2024-37905 or the next vulnerability affects your stack