What’s Vulnerable › Vulnerabilities
CVE-2024-37955: WordPress GutSlider – All in One Block Slider plugin <= 2.7.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Zakaria Binsaifullah GutSlider – All in One Block Slider allows Stored XSS.This issue affects GutSlider – All in One Block Slider: from n/a through 2.7.3.
Affected products
- Zakaria Binsaifullah GutSlider – All in One Block Slider: before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: Zakaria Binsaifullah GutSlider – All in One Block Slider 2.7.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/slider-blocks/wordpress-gutslider-all-in-one-block-slider-plugin-2-7-2-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/slider-blocks/wordpress-gutslider-all-in-one-block-slider-plugin-2-7-2-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37955 or the next vulnerability affects your stack