What’s Vulnerable › Vulnerabilities
CVE-2024-3799: Shell command injection in Phoniebox
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-78
Description
Insecure handling of POST header parameter body included in requests being sent to an instance of the open-source project Phoniebox allows an attacker to create a website, which – when visited by a user – will send malicious requests to multiple hosts on the local network. If such a request reaches the server, it will cause a shell command execution. This issue affects Phoniebox in all releases through 2.7. Newer 2.x releases were not tested, but they might also be vulnerable. Phoniebox in version 3.0 and higher are not affected.
Affected products
- Sourcefabric Phoniebox: through 2.7 — fixed in 3.0
How to fix
Upgrade to a fixed version: Sourcefabric Phoniebox 3.0. Check the vendor advisory for mitigations.
References
- https://cert.pl/en/posts/2024/07/CVE-2024-3798
- https://cert.pl/posts/2024/07/CVE-2024-3798
- https://github.com/MiczFlor/RPi-Jukebox-RFID/issues/2342
- https://cert.pl/en/posts/2024/07/CVE-2024-3798
- https://cert.pl/posts/2024/07/CVE-2024-3798
- https://github.com/MiczFlor/RPi-Jukebox-RFID/issues/2342
Get alerted when CVE-2024-3799 or the next vulnerability affects your stack