What’s Vulnerable › Vulnerabilities
CVE-2024-37996
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-476
Description
A vulnerability has been identified in JT Open (All versions < V11.5), JT2Go (All versions < V2406.0003), PLM XML SDK (All versions < V7.1.0.014), Teamcenter Visualization V14.2 (All versions < V14.2.0.13), Teamcenter Visualization V14.3 (All versions < V14.3.0.11), Teamcenter Visualization V2312 (All versions < V2312.0008), Teamcenter Visualization V2406 (All versions < V2406.0003). The affected applications contain a null pointer dereference vulnerability while parsing specially crafted XML files. An attacker could leverage this vulnerability to crash the application causing denial of service condition.
Affected products
- Siemens JT2Go: before V2406.0003 — fixed in V2406.0003
- Siemens JT Open: before V11.5 — fixed in V11.5
- Siemens PLM XML SDK: before V7.1.0.014 — fixed in V7.1.0.014
- Siemens Teamcenter Visualization V14.2: before V14.2.0.13 — fixed in V14.2.0.13
- Siemens Teamcenter Visualization V14.3: before V14.3.0.11 — fixed in V14.3.0.11
- Siemens Teamcenter Visualization V2312: before V2312.0008 — fixed in V2312.0008
- Siemens Teamcenter Visualization V2406: before V2406.0003 — fixed in V2406.0003
How to fix
Upgrade to a fixed version: Siemens JT2Go V2406.0003; Siemens JT Open V11.5; Siemens PLM XML SDK V7.1.0.014; Siemens Teamcenter Visualization V14.2 V14.2.0.13; Siemens Teamcenter Visualization V14.3 V14.3.0.11; Siemens Teamcenter Visualization V2312 V2312.0008; Siemens Teamcenter Visualization V2406 V2406.0003. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/html/ssa-824889.html
- https://cert-portal.siemens.com/productcert/html/ssa-959281.html
- https://cert-portal.siemens.com/productcert/html/ssa-824889.html
Get alerted when CVE-2024-37996 or the next vulnerability affects your stack