What’s Vulnerable › Vulnerabilities
CVE-2024-3813: tagDiv Composer <= 4.8 - Authenticated (Contributor+) Local File Inclusion via Shortcode
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-15 · updated 2026-06-17
- Weakness: CWE-98
Description
The tagDiv Composer plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.8 via the 'td_block_title' shortcode 'block_template_id' attribute. This makes it possible for authenticated attackers, with contributor-level and above permissions, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where php file type can be uploaded and included.
Affected products
- tagDiv Composer: before 4.9 — fixed in 4.9
How to fix
Upgrade to a fixed version: tagDiv Composer 4.9. Check the vendor advisory for mitigations.
References
- https://tagdiv.com/tagdiv-composer-page-builder-basics/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/87b7bc4a-4d2f-4bcb-a9d5-72e31c95c09e?source=cve
- https://tagdiv.com/tagdiv-composer-page-builder-basics/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/87b7bc4a-4d2f-4bcb-a9d5-72e31c95c09e?source=cve
Get alerted when CVE-2024-3813 or the next vulnerability affects your stack