What’s Vulnerable › Vulnerabilities
CVE-2024-3825: CSRF in BlazeMeter Jenkins plugin
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-352
Description
Versions of the BlazeMeter Jenkins plugin prior to 4.22 contain a flaw which results in credential enumeration
Affected products
- Jenkins Blazemeter Plugin: before 4.22 — fixed in 4.22
How to fix
Upgrade to a fixed version: Jenkins Blazemeter Plugin 4.22. Check the vendor advisory for mitigations.
References
- https://github.com/Blazemeter/blazemeter-jenkins-plugin/commit/11ec94f68136a0612ae1b37b5370053132cb2528
- https://portal.perforce.com/s/detail/a91PA000001STsvYAG
- https://github.com/Blazemeter/blazemeter-jenkins-plugin/commit/11ec94f68136a0612ae1b37b5370053132cb2528
- https://portal.perforce.com/s/detail/a91PA000001STsvYAG
Get alerted when CVE-2024-3825 or the next vulnerability affects your stack