What’s Vulnerable › Vulnerabilities
CVE-2024-38270
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-331
Description
An insufficient entropy vulnerability caused by the improper use of a randomness function with low entropy for web authentication tokens generation exists in the Zyxel GS1900-10HP firmware version V2.80(AAZI.0)C0. This vulnerability could allow a LAN-based attacker a slight chance to gain a valid session token if multiple authenticated sessions are alive.
Affected products
- Zyxel GS1900-10HP firmware: before 2.80\(aazi.1\)c0 — fixed in 2.80\(aazi.1\)c0
- Zyxel GS1900-16 firmware: before 2.80\(aahj.1\)c0 — fixed in 2.80\(aahj.1\)c0
- Zyxel GS1900-24 firmware: through 2.80\(aahl.1\)c0
- Zyxel GS1900-24E firmware: through 2.80\(aahk.1\)c0
- Zyxel GS1900-24EP firmware: before 2.80\(abto.1\)c0 — fixed in 2.80\(abto.1\)c0
- Zyxel GS1900-24HPv2 firmware: before 2.80\(abtp.1\)c0 — fixed in 2.80\(abtp.1\)c0
- Zyxel GS1900-48 firmware: before 2.80\(aahn.1\)c0 — fixed in 2.80\(aahn.1\)c0
- Zyxel GS1900-48HPv2 firmware: before 2.80\(abtq.1\)c0 — fixed in 2.80\(abtq.1\)c0
- Zyxel GS1900-8 firmware: before 2.80\(aahh.1\)c0 — fixed in 2.80\(aahh.1\)c0
- Zyxel GS1900-8HP firmware: before 2.80\(aahi.1\)c0 — fixed in 2.80\(aahi.1\)c0
How to fix
Upgrade to a fixed version: Zyxel GS1900-10HP firmware 2.80\(aazi.1\)c0; Zyxel GS1900-16 firmware 2.80\(aahj.1\)c0; Zyxel GS1900-24EP firmware 2.80\(abto.1\)c0; Zyxel GS1900-24HPv2 firmware 2.80\(abtp.1\)c0; Zyxel GS1900-48 firmware 2.80\(aahn.1\)c0; Zyxel GS1900-48HPv2 firmware 2.80\(abtq.1\)c0; Zyxel GS1900-8 firmware 2.80\(aahh.1\)c0; Zyxel GS1900-8HP firmware 2.80\(aahi.1\)c0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-38270 or the next vulnerability affects your stack