What’s Vulnerable › Vulnerabilities
CVE-2024-38271: Denial of Service in Quick Share
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-26 · updated 2026-06-17
- Weakness: CWE-404
Description
There exists a vulnerability in Quick Share/Nearby, where an attacker can force a victim to stay connected to a temporary hotspot created for the sharing. As part of the sequence of packets in a Quick Share connection over Bluetooth, the attacker forces the victim to connect to the attacker’s WiFi network and then sends an OfflineFrame that crashes Quick Share. This makes the Wifi connection to the attacker’s network last, instead of returning to the old network when the Quick Share session completes, allowing the attacker to be a MiTM. We recommend upgrading to version 1.0.1724.0 of Quick Share or above
Affected products
- Google Nearby: before 1.0.1724.0 — fixed in 1.0.1724.0
How to fix
Upgrade to a fixed version: Google Nearby 1.0.1724.0. Check the vendor advisory for mitigations.
References
- https://github.com/google/nearby/pull/2402
- https://github.com/google/nearby/pull/2433
- https://github.com/google/nearby/pull/2435
- https://github.com/google/nearby/pull/2589
- https://github.com/google/nearby/pull/2402
- https://github.com/google/nearby/pull/2433
- https://github.com/google/nearby/pull/2435
- https://github.com/google/nearby/pull/2589
Get alerted when CVE-2024-38271 or the next vulnerability affects your stack