What’s Vulnerable › Vulnerabilities
CVE-2024-38276: moodle: CSRF risks due to misuse of confirm_sesskey
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-18 · updated 2026-06-17
- Weakness: CWE-352
Description
Incorrect CSRF token checks resulted in multiple CSRF risks.
Affected products
- Fedoraproject Fedora: 39, 40
- Moodle: before 4.1.10; from 4.2.0 before 4.2.8; from 4.3.0 before 4.3.5; 4.4.0 — fixed in 4.1.10, 4.2.8, 4.3.5
How to fix
Upgrade to a fixed version: Moodle 4.1.10, 4.2.8, 4.3.5. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/F7AZYR7EXV6E5SQE2GYTNQE3NOENJCQ6/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GHTIX55J4Q4LEOMLNEA4OZSWVEENQX7E/
- https://moodle.org/mod/forum/discuss.php?d=459501
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/F7AZYR7EXV6E5SQE2GYTNQE3NOENJCQ6/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GHTIX55J4Q4LEOMLNEA4OZSWVEENQX7E/
- https://moodle.org/mod/forum/discuss.php?d=459501
Get alerted when CVE-2024-38276 or the next vulnerability affects your stack