What’s Vulnerable › Vulnerabilities
CVE-2024-38286: Apache Tomcat: Denial of Service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-07 · updated 2026-06-17
- Weakness: CWE-770
Description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue. Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.
Affected products
- Apache Tomcat: from 9.0.13 before 9.0.90; from 10.1.1 before 10.1.25; 10.1.0-milestone1, 10.1.0-milestone10, 10.1.0-milestone11, 10.1.0-milestone12, 10.1.0-milestone13, 10.1.0-milestone14 (+34) — fixed in 10.1.25, 9.0.90
- NetApp Ontap Tools: 9, 10
How to fix
Upgrade to a fixed version: Apache Tomcat 10.1.25, 9.0.90. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/wms60cvbsz3fpbz9psxtfx8r41jl6d4s
- http://www.openwall.com/lists/oss-security/2024/09/23/2
- https://lists.debian.org/debian-lts-announce/2025/01/msg00009.html
- https://security.netapp.com/advisory/ntap-20241101-0010/
Get alerted when CVE-2024-38286 or the next vulnerability affects your stack