What’s Vulnerable › Vulnerabilities
CVE-2024-38337: IBM Sterling Secure Proxy improper input validation
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-19 · updated 2026-06-17
- Weakness: CWE-732
Description
IBM Sterling Secure Proxy 6.0.0.0, 6.0.0.1, 6.0.0.2, 6.0.0.3, 6.1.0.0, and 6.2.0.0 could allow an unauthorized attacker to retrieve or alter sensitive information contents due to incorrect permission assignments.
Affected products
- IBM Sterling Secure Proxy: from 6.0.0.0 before 6.0.3.1; 6.1.0.0, 6.2.0.0 — fixed in 6.0.3.1
How to fix
Upgrade to a fixed version: IBM Sterling Secure Proxy 6.0.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-38337 or the next vulnerability affects your stack