What’s Vulnerable › Vulnerabilities
CVE-2024-38354: Cross-site Scripting in Hackmd.io Notes lead by HTML Injection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
CodiMD allows realtime collaborative markdown notes on all platforms. The notebook feature of Hackmd.io permits the rendering of iframe `HTML` tags with an improperly sanitized `name` attribute. This vulnerability enables attackers to perform cross-site scripting (XSS) attacks via DOM clobbering. This vulnerability is fixed in 2.5.4.
Affected products
- hackmdio codimd: before 2.5.4 — fixed in 2.5.4
How to fix
Upgrade to a fixed version: hackmdio codimd 2.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/hackmdio/codimd/security/advisories/GHSA-22jv-vch8-2vp9
- https://github.com/hackmdio/codimd/security/advisories/GHSA-22jv-vch8-2vp9
Get alerted when CVE-2024-38354 or the next vulnerability affects your stack