What’s Vulnerable › Vulnerabilities
CVE-2024-38360: Denial of service via Watched Words in Discourse
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-15 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open source platform for community discussion. In affected versions by creating replacement words with an almost unlimited number of characters, a moderator can reduce the availability of a Discourse instance. This issue has been addressed in stable version 3.2.3 and in current betas. Users are advised to upgrade. Users unable to upgrade may manually remove the long watched words either via SQL or Rails console.
Affected products
- discourse: before 3.3.0; before 3.3.2; 3.3.0-beta1, 3.3.0-beta2 — fixed in 3.3.0, 3.3.2
How to fix
Upgrade to a fixed version: discourse 3.3.0, 3.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/7b53e610c17e38be982dffefa4e5b5a709a3b990
- https://github.com/discourse/discourse/security/advisories/GHSA-68pm-hm8x-pq2p
- https://github.com/discourse/discourse/commit/7b53e610c17e38be982dffefa4e5b5a709a3b990
- https://github.com/discourse/discourse/security/advisories/GHSA-68pm-hm8x-pq2p
Get alerted when CVE-2024-38360 or the next vulnerability affects your stack