What’s Vulnerable › Vulnerabilities
CVE-2024-38363: Remote Code Execution (RCE) via Server Side Template Injection (SSTI) in Airbyte
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-1336
Description
Airbyte is a data integration platform for ELT pipelines. Airbyte connection builder docker image is vulnerable to RCE via SSTI which allows an authenticated remote attacker to execute arbitrary code on the server as the web server user. The connection builder is used to create and test new connectors. Sensitive information, such as credentials, could be exposed if a user tested a new connector on a compromised instance. The connection builder does not have access to any data processes. This vulnerability is fixed in 0.62.2.
Affected products
- Airbytehq: before 0.62.2 — fixed in 0.62.2
How to fix
Upgrade to a fixed version: Airbytehq 0.62.2. Check the vendor advisory for mitigations.
References
- https://github.com/airbytehq/airbyte/security/advisories/GHSA-4j3c-fgvx-xgqq
- https://github.com/airbytehq/airbyte/security/advisories/GHSA-4j3c-fgvx-xgqq
Get alerted when CVE-2024-38363 or the next vulnerability affects your stack