What’s Vulnerable › Vulnerabilities
CVE-2024-38372: Undici vulnerable to data leak when using response.arrayBuffer()
- Severity: low (CVSS 2.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-08 · updated 2026-06-17
- Weakness: CWE-201
Description
Undici is an HTTP/1.1 client, written from scratch for Node.js. Depending on network and process conditions of a `fetch()` request, `response.arrayBuffer()` might include portion of memory from the Node.js process. This has been patched in v6.19.2.
Affected products
- undici: from 6.14.0 before 6.19.2 — fixed in 6.19.2
How to fix
Upgrade to a fixed version: undici 6.19.2. Check the vendor advisory for mitigations.
References
- https://github.com/nodejs/undici/commit/f979ec3204ca489abf30e7d20e9fee9ea7711d36
- https://github.com/nodejs/undici/issues/3328
- https://github.com/nodejs/undici/issues/3337
- https://github.com/nodejs/undici/pull/3338
- https://github.com/nodejs/undici/security/advisories/GHSA-3g92-w8c5-73pq
- https://github.com/nodejs/undici/commit/f979ec3204ca489abf30e7d20e9fee9ea7711d36
- https://github.com/nodejs/undici/issues/3328
- https://github.com/nodejs/undici/issues/3337
- https://github.com/nodejs/undici/pull/3338
- https://github.com/nodejs/undici/security/advisories/GHSA-3g92-w8c5-73pq
- https://security.netapp.com/advisory/ntap-20240828-0009/
Get alerted when CVE-2024-38372 or the next vulnerability affects your stack