What’s Vulnerable › Vulnerabilities

CVE-2024-38379: Apache Allura: Stored authenticated XSS

Description

Apache Allura's neighborhood settings are vulnerable to a stored XSS attack.  Only neighborhood admins can access these settings, so the scope of risk is limited to configurations where neighborhood admins are not fully trusted. This issue affects Apache Allura: from 1.4.0 through 1.17.0. Users are recommended to upgrade to version 1.17.1, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Allura 1.17.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-38379 or the next vulnerability affects your stack