What’s Vulnerable › Vulnerabilities
CVE-2024-38396
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-16 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue was discovered in iTerm2 3.5.x before 3.5.2. Unfiltered use of an escape sequence to report a window title, in combination with the built-in tmux integration feature (enabled by default), allows an attacker to inject arbitrary code into the terminal, a different vulnerability than CVE-2024-38395.
Affected products
- iTerm2: from 3.5.0 before 3.5.2 — fixed in 3.5.2
How to fix
Upgrade to a fixed version: iTerm2 3.5.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/06/17/1
- https://gitlab.com/gnachman/iterm2/-/commit/fc60236a914d63fb70a5c632e211203a4f1bd4dd
- https://iterm2.com/downloads.html
- https://vin01.github.io/piptagole/escape-sequences/iterm2/rce/2024/06/16/iterm2-rce-window-title-tmux-integration.html
- http://www.openwall.com/lists/oss-security/2024/06/17/1
- https://gitlab.com/gnachman/iterm2/-/commit/fc60236a914d63fb70a5c632e211203a4f1bd4dd
- https://iterm2.com/downloads.html
- https://vin01.github.io/piptagole/escape-sequences/iterm2/rce/2024/06/16/iterm2-rce-window-title-tmux-integration.html
Get alerted when CVE-2024-38396 or the next vulnerability affects your stack