What’s Vulnerable › Vulnerabilities
CVE-2024-38439
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-16 · updated 2026-06-17
- Weakness: CWE-787
Description
Netatalk before 3.2.1 has an off-by-one error and resultant heap-based buffer overflow because of setting ibuf[PASSWDLEN] to '\0' in FPLoginExt in login in etc/uams/uams_pam.c. 2.4.1 and 3.1.19 are also fixed versions.
Affected products
- Netatalk: from 2.0.0 before 2.4.1; from 3.0.0 before 3.1.19; 3.2.0 — fixed in 2.4.1, 3.1.19
How to fix
Upgrade to a fixed version: Netatalk 2.4.1, 3.1.19. Check the vendor advisory for mitigations.
References
- https://github.com/Netatalk/netatalk/blob/90d91a9ac9a7d6132ab7620d31c8c23400949206/etc/uams/uams_pam.c#L316
- https://github.com/Netatalk/netatalk/issues/1096
- https://github.com/Netatalk/netatalk/security/advisories/GHSA-8r68-857c-4rqc
- https://netatalk.io/security/CVE-2024-38439
- https://github.com/Netatalk/netatalk/blob/90d91a9ac9a7d6132ab7620d31c8c23400949206/etc/uams/uams_pam.c#L316
- https://github.com/Netatalk/netatalk/issues/1096
- https://github.com/Netatalk/netatalk/security/advisories/GHSA-8r68-857c-4rqc
- https://lists.debian.org/debian-lts-announce/2024/11/msg00026.html
- https://netatalk.io/security/CVE-2024-38439
Get alerted when CVE-2024-38439 or the next vulnerability affects your stack