What’s Vulnerable › Vulnerabilities

CVE-2024-38479: Apache Traffic Server: Cache key plugin is vulnerable to cache poisoning attack

Description

Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.5. Users are recommended to upgrade to version 9.2.6, which fixes the issue, or 10.0.2, which does not have the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Traffic Server 9.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-38479 or the next vulnerability affects your stack