What’s Vulnerable › Vulnerabilities
CVE-2024-3850: Uniview NVR301-04S2-P4 Cross-site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Uniview NVR301-04S2-P4 is vulnerable to reflected cross-site scripting attack (XSS). An attacker could send a user a URL that if clicked on could execute malicious JavaScript in their browser. This vulnerability also requires authentication before it can be exploited, so the scope and severity is limited. Also, even if JavaScript is executed, no additional benefits are obtained.
Affected products
- Uniview NVR301-04S2-P4: before nvr-b3801.20.17.240507 — fixed in nvr-b3801.20.17.240507
How to fix
Upgrade to a fixed version: Uniview NVR301-04S2-P4 nvr-b3801.20.17.240507. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/news-events/ics-advisories/icsa-24-156-01
- https://github.com/r3naissance/nuclei-templates/blob/main/http/cves/2024/CVE-2024-3850.yaml
- https://www.cisa.gov/news-events/ics-advisories/icsa-24-156-01
Get alerted when CVE-2024-3850 or the next vulnerability affects your stack