What’s Vulnerable › Vulnerabilities
CVE-2024-38513: Fiber Session Middleware Token Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-01 · updated 2026-06-17
- Weakness: CWE-384
Description
Fiber is an Express-inspired web framework written in Go A vulnerability present in versions prior to 2.52.5 is a session middleware issue in GoFiber versions 2 and above. This vulnerability allows users to supply their own session_id value, resulting in the creation of a session with that key. If a website relies on the mere presence of a session for security purposes, this can lead to significant security risks, including unauthorized access and session fixation attacks. All users utilizing GoFiber's session middleware in the affected versions are impacted. The issue has been addressed in version 2.52.5. Users are strongly encouraged to upgrade to version 2.52.5 or higher to mitigate this vulnerability. Users who are unable to upgrade immediately can apply the following workarounds to reduce the risk: Either implement additional validation to ensure session IDs are not supplied by the user and are securely generated by the server, or regularly rotate session IDs and enforce strict session expiration policies.
Affected products
- gofiber fiber: before 2.52.5 — fixed in 2.52.5
How to fix
Upgrade to a fixed version: gofiber fiber 2.52.5. Check the vendor advisory for mitigations.
References
- https://github.com/gofiber/fiber/commit/66a881441b27322a331f1b526cf1eb6b3358a4d8
- https://github.com/gofiber/fiber/security/advisories/GHSA-98j2-3j3p-fw2v
- https://github.com/gofiber/fiber/commit/66a881441b27322a331f1b526cf1eb6b3358a4d8
- https://github.com/gofiber/fiber/security/advisories/GHSA-98j2-3j3p-fw2v
Get alerted when CVE-2024-38513 or the next vulnerability affects your stack