What’s Vulnerable › Vulnerabilities
CVE-2024-38527: Cross-site Scripting in ZenUML
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-26 · updated 2026-06-17
- Weakness: CWE-79
Description
ZenUML is JavaScript-based diagramming tool that requires no server, using Markdown-inspired text definitions and a renderer to create and modify sequence diagrams. Markdown-based comments in the ZenUML diagram syntax are susceptible to Cross-site Scripting (XSS). The comment feature allows the user to attach small notes for reference. This feature allows the user to enter in their comment in markdown comment, allowing them to use common markdown features, such as `**` for bolded text. However, the markdown text is currently not sanitized before rendering, allowing an attacker to enter a malicious payload for the comment which leads to XSS. This puts existing applications that use ZenUML unsandboxed at risk of arbitrary JavaScript execution when rendering user-controlled diagrams. This vulnerability was patched in version 3.23.25,
Affected products
- Mermaidjs Zenuml-Core: through 3.0.0
References
- https://github.com/mermaid-js/zenuml-core/commit/ad7545b33f5f27466cbf357beb65969ca1953e3c
- https://github.com/mermaid-js/zenuml-core/security/advisories/GHSA-q6xv-jm4v-349h
- https://github.com/mermaid-js/zenuml-core/commit/ad7545b33f5f27466cbf357beb65969ca1953e3c
- https://github.com/mermaid-js/zenuml-core/security/advisories/GHSA-q6xv-jm4v-349h
Get alerted when CVE-2024-38527 or the next vulnerability affects your stack