What’s Vulnerable › Vulnerabilities
CVE-2024-38560: scsi: bfa: Ensure the copied buf is NUL terminated
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-10-15
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: bfa: Ensure the copied buf is NUL terminated Currently, we allocate a nbytes-sized kernel buffer and copy nbytes from userspace to that buffer. Later, we use sscanf on this buffer but we don't ensure that the string is terminated inside the buffer, this can lead to OOB read when using sscanf. Fix this issue by using memdup_user_nul instead of memdup_user.
Affected products
- Linux kernel: from 3.19 before 4.19.316; from 4.20 before 5.4.278; from 5.5 before 5.10.219; from 5.11 before 5.15.161; from 5.16 before 6.1.93; from 6.2 before 6.6.33 — fixed in 4.19.316, 5.10.219, 5.15.161, 5.4.278, 6.1.93, 6.6.33
How to fix
Upgrade to a fixed version: Linux kernel 4.19.316, 5.10.219, 5.15.161, 5.4.278. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/00b425ff0891283207d7bad607a2412225274d7a
- https://git.kernel.org/stable/c/13d0cecb4626fae67c00c84d3c7851f6b62f7df3
- https://git.kernel.org/stable/c/1708e3cf2488788cba5489e4f913d227de757baf
- https://git.kernel.org/stable/c/204714e68015d6946279719fd464ecaf57240f35
- https://git.kernel.org/stable/c/481fc0c8617304a67649027c4a44723a139a0462
- https://git.kernel.org/stable/c/595a6b98deec01b6dbb20139f71edcd5fb760ec2
- https://git.kernel.org/stable/c/7510fab46b1cbd1680e2a096e779aec3334b4143
- https://git.kernel.org/stable/c/7d3e694c4fe30f3aba9cd5ae86fb947a54c3db5c
- https://git.kernel.org/stable/c/ecb76200f5557a2886888aaa53702da1ab9e6cdf
- https://git.kernel.org/stable/c/00b425ff0891283207d7bad607a2412225274d7a
- https://git.kernel.org/stable/c/13d0cecb4626fae67c00c84d3c7851f6b62f7df3
- https://git.kernel.org/stable/c/1708e3cf2488788cba5489e4f913d227de757baf
Get alerted when CVE-2024-38560 or the next vulnerability affects your stack