What’s Vulnerable › Vulnerabilities
CVE-2024-38567: wifi: carl9170: add a proper sanity check for endpoints
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: carl9170: add a proper sanity check for endpoints Syzkaller reports [1] hitting a warning which is caused by presence of a wrong endpoint type at the URB sumbitting stage. While there was a check for a specific 4th endpoint, since it can switch types between bulk and interrupt, other endpoints are trusted implicitly. Similar warning is triggered in a couple of other syzbot issues [2]. Fix the issue by doing a comprehensive check of all endpoints taking into account difference between high- and full-speed configuration. [1] Syzkaller report: ... WARNING: CPU: 0 PID: 4721 at drivers/usb/core/urb.c:504 usb_submit_urb+0xed6/0x1880 drivers/usb/core/urb.c:504 ... Call Trace: <TASK> carl9170_usb_send_rx_irq_urb+0x273/0x340 drivers/net/wireless/ath/carl9170/usb.c:504 carl9170_usb_init_device drivers/net/wireless/ath/carl9170/usb.c:939 [inline] carl9170_usb_firmware_finish drivers/net/wireless/ath/carl9170/usb.c:999 [inline] carl9170_usb_firmware_step2+0x175/0x240 drivers/net/wireless/ath/carl9170/usb.c:1028 request_firmware_work_func+0x130/0x240 drivers/base/firmware_loader/main.c:1107 process_one_work+0x9bf/0x1710 kernel/workqueue.c:2289 worker_thread+0x669/0x1090 kernel/workqueue.c:2436 kthread+0x2e8/0x3a0 kernel/kthread.c:376 ret_from_fork+0x1f/0x30 arch/x86/entry/entry_64.S:308 </TASK> [2] Related syzkaller crashes:
Affected products
- Linux kernel: from 2.6.37 before 4.19.316; from 4.20 before 5.4.278; from 5.5 before 5.10.219; from 5.11 before 5.15.161; from 5.16 before 6.1.93; from 6.2 before 6.6.33 — fixed in 4.19.316, 5.10.219, 5.15.161, 5.4.278, 6.1.93, 6.6.33
How to fix
Upgrade to a fixed version: Linux kernel 4.19.316, 5.10.219, 5.15.161, 5.4.278. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/03ddc74bdfd71b84a55c9f2185d8787f258422cd
- https://git.kernel.org/stable/c/0fa08a55201ab9be72bacb8ea93cf752d338184f
- https://git.kernel.org/stable/c/265c3cda471c26e0f25d0c755da94e1eb15d7a0c
- https://git.kernel.org/stable/c/62eb07923f3693d55b0c2d9a5a4f1ad72cb6b8fd
- https://git.kernel.org/stable/c/6a9892bf24c906b4d6b587f8759ca38bff672582
- https://git.kernel.org/stable/c/8650725bb0a48b206d5a8ddad3a7488f9a5985b7
- https://git.kernel.org/stable/c/ac3ed46a8741d464bc70ebdf7433c1d786cf329d
- https://git.kernel.org/stable/c/b6dd09b3dac89b45d1ea3e3bd035a3859c0369a0
- https://git.kernel.org/stable/c/eb0f2fc3ff5806cc572cd9055ce7c52a01e97645
- https://git.kernel.org/stable/c/03ddc74bdfd71b84a55c9f2185d8787f258422cd
- https://git.kernel.org/stable/c/0fa08a55201ab9be72bacb8ea93cf752d338184f
- https://git.kernel.org/stable/c/265c3cda471c26e0f25d0c755da94e1eb15d7a0c
Get alerted when CVE-2024-38567 or the next vulnerability affects your stack