What’s Vulnerable › Vulnerabilities
CVE-2024-38569: drivers/perf: hisi_pcie: Fix out-of-bound access when valid event group
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-08-04
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: drivers/perf: hisi_pcie: Fix out-of-bound access when valid event group The perf tool allows users to create event groups through following cmd [1], but the driver does not check whether the array index is out of bounds when writing data to the event_group array. If the number of events in an event_group is greater than HISI_PCIE_MAX_COUNTERS, the memory write overflow of event_group array occurs. Add array index check to fix the possible array out of bounds violation, and return directly when write new events are written to array bounds. There are 9 different events in an event_group. [1] perf stat -e '{pmu/event1/, ... ,pmu/event9/}'
Affected products
- Linux kernel: from 5.17 before 6.1.93; from 6.2 before 6.6.33; from 6.7 before 6.8.12; from 6.9 before 6.9.3 — fixed in 6.1.93, 6.6.33, 6.8.12, 6.9.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1.93, 6.6.33, 6.8.12, 6.9.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3d1face00ebb7996842aee4214d7d0fb0c77b1e9
- https://git.kernel.org/stable/c/567d34626c22b36579ec0abfdf5eda2949044220
- https://git.kernel.org/stable/c/77fce82678ea5fd51442e62febec2004f79e041b
- https://git.kernel.org/stable/c/8e9aab2492178f25372f1820bfd9289fbd74efd0
- https://git.kernel.org/stable/c/ff48247144d13a3a0817127703724256008efa78
- https://git.kernel.org/stable/c/3d1face00ebb7996842aee4214d7d0fb0c77b1e9
- https://git.kernel.org/stable/c/567d34626c22b36579ec0abfdf5eda2949044220
- https://git.kernel.org/stable/c/77fce82678ea5fd51442e62febec2004f79e041b
- https://git.kernel.org/stable/c/8e9aab2492178f25372f1820bfd9289fbd74efd0
- https://git.kernel.org/stable/c/ff48247144d13a3a0817127703724256008efa78
Get alerted when CVE-2024-38569 or the next vulnerability affects your stack