What’s Vulnerable › Vulnerabilities
CVE-2024-38573: cppc_cpufreq: Fix possible null pointer dereference
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: cppc_cpufreq: Fix possible null pointer dereference cppc_cpufreq_get_rate() and hisi_cppc_cpufreq_get_rate() can be called from different places with various parameters. So cpufreq_cpu_get() can return null as 'policy' in some circumstances. Fix this bug by adding null return check. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 5.11 before 5.15.161; from 5.16 before 6.1.93; from 6.2 before 6.6.33; from 6.7 before 6.8.12; from 6.9 before 6.9.3 — fixed in 5.15.161, 6.1.93, 6.6.33, 6.8.12, 6.9.3
How to fix
Upgrade to a fixed version: Linux kernel 5.15.161, 6.1.93, 6.6.33, 6.8.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/769c4f355b7962895205b86ad35617873feef9a5
- https://git.kernel.org/stable/c/9a185cc5a79ba408e1c73375706630662304f618
- https://git.kernel.org/stable/c/b18daa4ec727c0266de5bfc78e818d168cc4aedf
- https://git.kernel.org/stable/c/cf7de25878a1f4508c69dc9f6819c21ba177dbfe
- https://git.kernel.org/stable/c/dfec15222529d22b15e5b0d63572a9e39570cab4
- https://git.kernel.org/stable/c/f84b9b25d045e67a7eee5e73f21278c8ab06713c
- https://git.kernel.org/stable/c/769c4f355b7962895205b86ad35617873feef9a5
- https://git.kernel.org/stable/c/9a185cc5a79ba408e1c73375706630662304f618
- https://git.kernel.org/stable/c/b18daa4ec727c0266de5bfc78e818d168cc4aedf
- https://git.kernel.org/stable/c/cf7de25878a1f4508c69dc9f6819c21ba177dbfe
- https://git.kernel.org/stable/c/dfec15222529d22b15e5b0d63572a9e39570cab4
- https://git.kernel.org/stable/c/f84b9b25d045e67a7eee5e73f21278c8ab06713c
Get alerted when CVE-2024-38573 or the next vulnerability affects your stack