What’s Vulnerable › Vulnerabilities
CVE-2024-38580: epoll: be better about file lifetimes
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: epoll: be better about file lifetimes epoll can call out to vfs_poll() with a file pointer that may race with the last 'fput()'. That would make f_count go down to zero, and while the ep->mtx locking means that the resulting file pointer tear-down will be blocked until the poll returns, it means that f_count is already dead, and any use of it won't actually get a reference to the file any more: it's dead regardless. Make sure we have a valid ref on the file pointer before we call down to vfs_poll() from the epoll routines.
Affected products
- Linux kernel: before 5.15.161; from 5.16 before 6.1.93; from 6.2 before 6.6.33; from 6.7 before 6.8.12; 6.9-rc1, 6.9-rc2, 6.9-rc3, 6.9-rc4, 6.9-rc5, 6.9-rc6 — fixed in 5.15.161, 6.1.93, 6.6.33, 6.8.12
How to fix
Upgrade to a fixed version: Linux kernel 5.15.161, 6.1.93, 6.6.33, 6.8.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/16e3182f6322575eb7c12e728ad3c7986a189d5d
- https://git.kernel.org/stable/c/4efaa5acf0a1d2b5947f98abb3acf8bfd966422b
- https://git.kernel.org/stable/c/4f65f4defe4e23659275ce5153541cd4f76ce2d2
- https://git.kernel.org/stable/c/559214eb4e5c3d05e69428af2fae2691ba1eb784
- https://git.kernel.org/stable/c/cbfd1088e24ec4c1199756a37cb8e4cd0a4b016e
- https://git.kernel.org/stable/c/16e3182f6322575eb7c12e728ad3c7986a189d5d
- https://git.kernel.org/stable/c/4efaa5acf0a1d2b5947f98abb3acf8bfd966422b
- https://git.kernel.org/stable/c/4f65f4defe4e23659275ce5153541cd4f76ce2d2
- https://git.kernel.org/stable/c/559214eb4e5c3d05e69428af2fae2691ba1eb784
- https://git.kernel.org/stable/c/cbfd1088e24ec4c1199756a37cb8e4cd0a4b016e
Get alerted when CVE-2024-38580 or the next vulnerability affects your stack