What’s Vulnerable › Vulnerabilities
CVE-2024-38590: RDMA/hns: Modify the print level of CQE error
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: RDMA/hns: Modify the print level of CQE error Too much print may lead to a panic in kernel. Change ibdev_err() to ibdev_err_ratelimited(), and change the printing level of cqe dump to debug level.
Affected products
- Linux kernel: from 5.8 before 5.10.219; from 5.11 before 5.15.161; from 5.16 before 6.1.93; from 6.2 before 6.6.33; from 6.7 before 6.8.12; from 6.9 before 6.9.3 — fixed in 5.10.219, 5.15.161, 6.1.93, 6.6.33, 6.8.12, 6.9.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.219, 5.15.161, 6.1.93, 6.6.33. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/06cf121346bbd3d83a5eea05bb87666c6b279990
- https://git.kernel.org/stable/c/17f3741c65c4a042ae8ba094068b07a4b77e213c
- https://git.kernel.org/stable/c/349e859952285ab9689779fb46de163f13f18f43
- https://git.kernel.org/stable/c/45b31be4dd22827903df15c548b97b416790139b
- https://git.kernel.org/stable/c/6f541a89ced8305da459e3ab0006e7528cf7da7b
- https://git.kernel.org/stable/c/817a10a6df9354e67561922d2b7fce48dfbebc55
- https://git.kernel.org/stable/c/cc699b7eb2bc963c12ffcd37f80f45330d2924bd
- https://git.kernel.org/stable/c/06cf121346bbd3d83a5eea05bb87666c6b279990
- https://git.kernel.org/stable/c/17f3741c65c4a042ae8ba094068b07a4b77e213c
- https://git.kernel.org/stable/c/349e859952285ab9689779fb46de163f13f18f43
- https://git.kernel.org/stable/c/45b31be4dd22827903df15c548b97b416790139b
- https://git.kernel.org/stable/c/6f541a89ced8305da459e3ab0006e7528cf7da7b
Get alerted when CVE-2024-38590 or the next vulnerability affects your stack