What’s Vulnerable › Vulnerabilities
CVE-2024-38607: macintosh/via-macii: Fix "BUG: sleeping function called from invalid context"
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: macintosh/via-macii: Fix "BUG: sleeping function called from invalid context" The via-macii ADB driver calls request_irq() after disabling hard interrupts. But disabling interrupts isn't necessary here because the VIA shift register interrupt was masked during VIA1 initialization.
Affected products
- Linux kernel: from 2.6.13 before 4.19.316; from 4.20 before 5.4.278; from 5.5 before 5.10.219; from 5.11 before 5.15.161; from 5.16 before 6.1.93; from 6.2 before 6.6.33 — fixed in 4.19.316, 5.10.219, 5.15.161, 5.4.278, 6.1.93, 6.6.33
How to fix
Upgrade to a fixed version: Linux kernel 4.19.316, 5.10.219, 5.15.161, 5.4.278. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/010d4cb19bb13f423e3e746b824f314a9bf3e9a9
- https://git.kernel.org/stable/c/1e9c3f2caec548cfa7a65416ec4e6006e542f18e
- https://git.kernel.org/stable/c/280619bbdeac186fb320fab3d61122d2a085def8
- https://git.kernel.org/stable/c/2907d409ce5946390f513976f0454888d37d1058
- https://git.kernel.org/stable/c/5900a88e897e6deb1bdce09ee34167a81c2da89d
- https://git.kernel.org/stable/c/787fb79efc15b3b86442ecf079b8148f173376d7
- https://git.kernel.org/stable/c/d301a71c76ee4c384b4e03cdc320a55f5cf1df05
- https://git.kernel.org/stable/c/d43a8c7ec0841e0ff91a968770aeca83f0fd4c56
- https://git.kernel.org/stable/c/e4ff8bcfb2841fe4e17e5901578b632adb89036d
- https://git.kernel.org/stable/c/010d4cb19bb13f423e3e746b824f314a9bf3e9a9
- https://git.kernel.org/stable/c/1e9c3f2caec548cfa7a65416ec4e6006e542f18e
- https://git.kernel.org/stable/c/280619bbdeac186fb320fab3d61122d2a085def8
Get alerted when CVE-2024-38607 or the next vulnerability affects your stack