What’s Vulnerable › Vulnerabilities
CVE-2024-38620: Bluetooth: HCI: Remove HCI_AMP support
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-20 · updated 2026-08-23
Description
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: HCI: Remove HCI_AMP support Since BT_HS has been remove HCI_AMP controllers no longer has any use so remove it along with the capability of creating AMP controllers. Since we no longer need to differentiate between AMP and Primary controllers, as only HCI_PRIMARY is left, this also remove hdev->dev_type altogether.
Affected products
- Linux kernel: from 4.3 before 6.6.33; from 6.7 before 6.8.12; from 6.9 before 6.9.3 — fixed in 6.6.33, 6.8.12, 6.9.3
How to fix
Upgrade to a fixed version: Linux kernel 6.6.33, 6.8.12, 6.9.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5af2e235b0d5b797e9531a00c50058319130e156
- https://git.kernel.org/stable/c/84a4bb6548a29326564f0e659fb8064503ecc1c7
- https://git.kernel.org/stable/c/9e6cf0eccfe15b67bf9773ecd101162dfdfed5e2
- https://git.kernel.org/stable/c/af1d425b6dc67cd67809f835dd7afb6be4d43e03
- https://git.kernel.org/stable/c/d3c7b012d912b31ad23b9349c0e499d6dddd48ec
- https://git.kernel.org/stable/c/5af2e235b0d5b797e9531a00c50058319130e156
- https://git.kernel.org/stable/c/84a4bb6548a29326564f0e659fb8064503ecc1c7
- https://git.kernel.org/stable/c/af1d425b6dc67cd67809f835dd7afb6be4d43e03
- https://git.kernel.org/stable/c/d3c7b012d912b31ad23b9349c0e499d6dddd48ec
Get alerted when CVE-2024-38620 or the next vulnerability affects your stack