What’s Vulnerable › Vulnerabilities
CVE-2024-38632: vfio/pci: fix potential memory leak in vfio_intx_enable()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-21 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: vfio/pci: fix potential memory leak in vfio_intx_enable() If vfio_irq_ctx_alloc() failed will lead to 'name' memory leak.
Affected products
- Linux kernel: from 6.6.24 before 6.6.33; from 6.9 before 6.9.4 — fixed in 6.6.33, 6.9.4
How to fix
Upgrade to a fixed version: Linux kernel 6.6.33, 6.9.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0bd22a4966d55f1d2c127a53300d5c2b50152376
- https://git.kernel.org/stable/c/35fef97c33f3d3ca0455f9a8e2a3f2c1f8cc9140
- https://git.kernel.org/stable/c/82b951e6fbd31d85ae7f4feb5f00ddd4c5d256e2
- https://git.kernel.org/stable/c/91ced077db2062604ec270b1046f8337e9090079
- https://git.kernel.org/stable/c/a6d810554d7d9d07041f14c5fcd453f3d3fed594
- https://git.kernel.org/stable/c/0bd22a4966d55f1d2c127a53300d5c2b50152376
- https://git.kernel.org/stable/c/35fef97c33f3d3ca0455f9a8e2a3f2c1f8cc9140
- https://git.kernel.org/stable/c/82b951e6fbd31d85ae7f4feb5f00ddd4c5d256e2
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-38632 or the next vulnerability affects your stack