What’s Vulnerable › Vulnerabilities
CVE-2024-38674: WordPress SKT Addons for Elementor plugin <= 3.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in SKT Themes SKT Addons for Elementor allows Stored XSS.This issue affects SKT Addons for Elementor: from n/a through 3.0.
Affected products
- sonalsinha21 SKT Addons for Elementor: before 3.2 — fixed in 3.2
How to fix
Upgrade to a fixed version: sonalsinha21 SKT Addons for Elementor 3.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/skt-addons-for-elementor/wordpress-skt-addons-for-elementor-plugin-2-1-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/skt-addons-for-elementor/wordpress-skt-addons-for-elementor-plugin-2-1-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-38674 or the next vulnerability affects your stack