What’s Vulnerable › Vulnerabilities
CVE-2024-38681: WordPress Magical Addons For Elementor plugin <= 1.1.41 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Noor alam Magical Addons For Elementor allows Stored XSS.This issue affects Magical Addons For Elementor: from n/a through 1.1.41.
Affected products
- nalam-1 Magical Addons For Elementor ( Header Footer Builder, Free Elementor Widgets, Elementor Templates Library ): before 1.1.42 — fixed in 1.1.42
How to fix
Upgrade to a fixed version: nalam-1 Magical Addons For Elementor ( Header Footer Builder, Free Elementor Widgets, Elementor Templates Library ) 1.1.42. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/magical-addons-for-elementor/wordpress-magical-addons-for-elementor-plugin-1-1-41-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/magical-addons-for-elementor/wordpress-magical-addons-for-elementor-plugin-1-1-41-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-38681 or the next vulnerability affects your stack