What’s Vulnerable › Vulnerabilities
CVE-2024-38711: WordPress Link Library plugin <= 7.7.1 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Yannick Lefebvre Link Library allows Reflected XSS.This issue affects Link Library: from n/a through 7.7.1.
Affected products
- Link Library: before 7.7.2 — fixed in 7.7.2
How to fix
Upgrade to a fixed version: Link Library 7.7.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/link-library/wordpress-link-library-plugin-7-7-1-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/link-library/wordpress-link-library-plugin-7-7-1-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-38711 or the next vulnerability affects your stack