What’s Vulnerable › Vulnerabilities
CVE-2024-38712: WordPress Qi Blocks plugin <= 1.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Qode Qi Blocks qi-blocks.This issue affects Qi Blocks: from n/a through <= 1.3.
Affected products
- qodeinteractive Qi Blocks: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: qodeinteractive Qi Blocks 1.3.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/qi-blocks/vulnerability/wordpress-qi-blocks-plugin-1-3-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/qi-blocks/wordpress-qi-blocks-plugin-1-3-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-38712 or the next vulnerability affects your stack