What’s Vulnerable › Vulnerabilities
CVE-2024-38782: WordPress Leaflet Maps Marker plugin <= 3.12.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in MapsMarker.Com e.U. Leaflet Maps Marker allows Stored XSS.This issue affects Leaflet Maps Marker: from n/a through 3.12.9.
Affected products
- Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps): before 3.12.10 — fixed in 3.12.10
How to fix
Upgrade to a fixed version: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) 3.12.10. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/leaflet-maps-marker/wordpress-leaflet-maps-marker-plugin-3-12-9-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/leaflet-maps-marker/wordpress-leaflet-maps-marker-plugin-3-12-9-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-38782 or the next vulnerability affects your stack