What’s Vulnerable › Vulnerabilities

CVE-2024-38808: CVE-2024-38808: Spring Expression DoS Vulnerability

Description

In Spring Framework versions 5.3.0 - 5.3.38 and older unsupported versions, it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial of service (DoS) condition. Specifically, an application is vulnerable when the following is true: * The application evaluates user-supplied SpEL expressions.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.3.39; Spring Framework 5.3.39, 6.0+. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-38808 or the next vulnerability affects your stack