What’s Vulnerable › Vulnerabilities
CVE-2024-38818
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-09 · updated 2026-06-17
- Weakness: CWE-269
Description
VMware NSX contains a local privilege escalation vulnerability. An authenticated malicious actor may exploit this vulnerability to obtain permissions from a separate group role than previously assigned.
Affected products
- VMware Cloud Foundation: from 5.0 before Async_Patch_to_4.2.1 — fixed in Async_Patch_to_4.2.1
- VMware NSX: from 4.1.0 before 4.2.1 — fixed in 4.2.1
- VMware Nsx-T: from 3.2.0 before 3.2.4.1 — fixed in 3.2.4.1
- VMware NSX, VMware Cloud Foundation: VMware NSX 4.x, VMware Cloud Foundation 5.x
How to fix
Upgrade to a fixed version: VMware Cloud Foundation Async_Patch_to_4.2.1; VMware NSX 4.2.1; VMware Nsx-T 3.2.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-38818 or the next vulnerability affects your stack