What’s Vulnerable › Vulnerabilities
CVE-2024-38826: CVE-2024-38826 Cloud Controller Denial of Service Attack
- Severity: medium (CVSS 5.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-400
Description
Authenticated users can upload specifically crafted files to leak server resources. This behavior can potentially be used to run a denial of service attack against Cloud Controller. The Cloud Foundry project recommends upgrading the following releases: * Upgrade capi release version to 1.194.0 or greater * Upgrade cf-deployment version to v44.1.0 or greater. This includes a patched capi release
Affected products
- Cloud Foundry: before 1.194 — fixed in 1.194
How to fix
Upgrade to a fixed version: Cloud Foundry 1.194. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-38826 or the next vulnerability affects your stack