What’s Vulnerable › Vulnerabilities
CVE-2024-38856: Apache OFBiz Incorrect Authorization Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-08-27
- EPSS: 99.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-05 · updated 2026-06-17
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
Affected products
- Apache Software Foundation Apache OFBiz: before 18.12.15 — fixed in 18.12.15
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 18.12.15. Check the vendor advisory for mitigations.
References
- https://issues.apache.org/jira/browse/OFBIZ-13128
- https://lists.apache.org/thread/olxxjk6b13sl3wh9cmp0k2dscvp24l7w
- https://ofbiz.apache.org/download.html
- https://ofbiz.apache.org/security.html
- http://www.openwall.com/lists/oss-security/2024/08/04/1
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-38856
Get alerted when CVE-2024-38856 or the next vulnerability affects your stack