What’s Vulnerable › Vulnerabilities
CVE-2024-3886: tagDiv Composer <= 5.0 - Reflected Cross-Site Scripting via envato_code[]
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-31 · updated 2026-06-17
- Weakness: CWE-79
Description
The tagDiv Composer plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘envato_code[]’ parameter in all versions up to, and including, 5.0 due to insufficient input sanitization and output escaping within the on_ajax_check_envato_code function. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- tagDiv Composer: before 5.1 — fixed in 5.1
How to fix
Upgrade to a fixed version: tagDiv Composer 5.1. Check the vendor advisory for mitigations.
References
- https://tagdiv.com/newspaper/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ed9db9c1-c6b5-459e-9820-ec4ee47b244e?source=cve
Get alerted when CVE-2024-3886 or the next vulnerability affects your stack