What’s Vulnerable › Vulnerabilities
CVE-2024-3899: Envira Gallery < 1.8.15 - Author+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gallery Plugin for WordPress WordPress plugin before 1.8.15 does not sanitise and escape some of its image settings, which could allow users with post-writing privilege such as Author to perform Cross-Site Scripting attacks.
Affected products
- smub Envira Gallery – Image Photo Gallery, Albums, Video Gallery, Slideshows & More: before 1.8.15 — fixed in 1.8.15
How to fix
Upgrade to a fixed version: smub Envira Gallery – Image Photo Gallery, Albums, Video Gallery, Slideshows & More 1.8.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-3899 or the next vulnerability affects your stack