What’s Vulnerable › Vulnerabilities
CVE-2024-38999: jrburke requirejs vulnerable to prototype pollution
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-01 · updated 2026-06-17
- Weakness: CWE-1321
Description
jrburke requirejs v2.3.6 was discovered to contain a prototype pollution via the function s.contexts._.configure. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.
Affected products
- Jrburke Requirejs: 2.3.6
- Npm Requirejs: before 2.3.7 — fixed in 2.3.7
How to fix
Upgrade to a fixed version: Npm Requirejs 2.3.7. Check the vendor advisory for mitigations.
References
- https://gist.github.com/mestrtee/9acae342285bd2998fa09ebcb1e6d30a
- https://gist.github.com/mestrtee/9acae342285bd2998fa09ebcb1e6d30a
Get alerted when CVE-2024-38999 or the next vulnerability affects your stack