What’s Vulnerable › Vulnerabilities
CVE-2024-39001
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-01 · updated 2026-06-17
- Weakness: CWE-1321
Description
ag-grid-enterprise v31.3.2 was discovered to contain a prototype pollution via the component _ModuleSupport.jsonApply. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.
Affected products
- HackerOne ag-grid node module: before 31.3.4; from 32.0.0 before 32.0.2 — fixed in 31.3.4, 32.0.2
- Ag-Grid Ag Charts: before 9.3.2; from 10.0.0 before 10.0.2 — fixed in 10.0.2, 9.3.2
How to fix
Upgrade to a fixed version: HackerOne ag-grid node module 31.3.4, 32.0.2; Ag-Grid Ag Charts 10.0.2, 9.3.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/mestrtee/18e8c27f3a6376e7cf082cfe1ca766fa
- https://gist.github.com/mestrtee/c1590660750744f25e86ba1bf240844b
- https://gist.github.com/mestrtee/f8037d492dab0d77bca719e05d31c08b
- https://gist.github.com/mestrtee/18e8c27f3a6376e7cf082cfe1ca766fa
- https://gist.github.com/mestrtee/c1590660750744f25e86ba1bf240844b
- https://gist.github.com/mestrtee/f8037d492dab0d77bca719e05d31c08b
Get alerted when CVE-2024-39001 or the next vulnerability affects your stack