What’s Vulnerable › Vulnerabilities
CVE-2024-3901: Genesis Blocks <= 3.1.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Genesis Blocks WordPress plugin through 3.1.3 does not properly escape attributes provided to some of its custom blocks, making it possible for users allowed to write posts (like those with the contributor role) to conduct Stored XSS attacks.
Affected products
- Genesis Blocks: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: Genesis Blocks 3.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-3901 or the next vulnerability affects your stack