What’s Vulnerable › Vulnerabilities
CVE-2024-3919: OpenPGP Form Encryption for WordPress < 1.5.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The OpenPGP Form Encryption for WordPress plugin before 1.5.1 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- OpenPGP Form Encryption for WordPress: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: OpenPGP Form Encryption for WordPress 1.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4e38c7d9-5b6a-4dfc-8f22-3ff30565ce43/
- https://wpscan.com/vulnerability/4e38c7d9-5b6a-4dfc-8f22-3ff30565ce43/
Get alerted when CVE-2024-3919 or the next vulnerability affects your stack