What’s Vulnerable › Vulnerabilities
CVE-2024-3922: Dokan Pro <= 3.10.3 - Unauthenticated SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 52.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-89
Description
The Dokan Pro plugin for WordPress is vulnerable to SQL Injection via the 'code' parameter in all versions up to, and including, 3.10.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- dokaninc Dokan: AI Powered WooCommerce Multivendor Marketplace Solution – Build Your Own Amazon, eBay, Etsy: before 3.11.0 — fixed in 3.11.0
How to fix
Upgrade to a fixed version: dokaninc Dokan: AI Powered WooCommerce Multivendor Marketplace Solution – Build Your Own Amazon, eBay, Etsy 3.11.0. Check the vendor advisory for mitigations.
References
- https://dokan.co/docs/wordpress/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9de41de-f2f7-4b16-8ec9-d30bbd3d8786?source=cve
- https://dokan.co/docs/wordpress/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9de41de-f2f7-4b16-8ec9-d30bbd3d8786?source=cve
Get alerted when CVE-2024-3922 or the next vulnerability affects your stack